All systems operational

Data lag of NFT owners on Polygon

Resolved
Degraded performance
Started about 1 year ago Lasted 3 minutes

Affected

Data health
Polygon
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    The lag has caught up. We implemented a fix and are currently monitoring the result.

  • Investigating
    Investigating

    We are currently investigating this incident.