Report an issue
Get updates
Email
Slack
Google Chat
Webhook
API
Report an issue
Get updates
All systems operational
Show current status
Resolved
Data lag resolved on Ethereum
Started
April 05, 2023 at 6:26 PM
Status
Resolved after less than a minute
Impact
Operational
Affected
Data health
Ethereum
Polygon
Resolved
April 05, 2023 at 6:26 PM
Resolved
April 05, 2023 at 6:26 PM
We are experiencing data lag and are continuing to work on a fix for this incident.